Rectangle3d Constructor (Plane, Point3d, Point3d) |
Initializes a new rectangle from a base plane and two corner points.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public Rectangle3d(
Plane plane,
Point3d cornerA,
Point3d cornerB
)
Public Sub New (
plane As Plane,
cornerA As Point3d,
cornerB As Point3d
)
Parameters
- plane
- Type: Rhino.GeometryPlane
Base plane for Rectangle. - cornerA
- Type: Rhino.GeometryPoint3d
First corner of Rectangle (will be projected onto plane). - cornerB
- Type: Rhino.GeometryPoint3d
Second corner of Rectangle (will be projected onto plane).
See Also