Click or drag to resize

LinearDimension Class

Represents a linear dimension
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class LinearDimension : Dimension

The LinearDimension type exposes the following members.

Constructors
  NameDescription
Public methodLinearDimension
Initializes a new instance of the LinearDimension class
Protected methodLinearDimension(SerializationInfo, StreamingContext)
Protected constructor used in serialization.
Public methodCode exampleLinearDimension(Plane, Point2d, Point2d, Point2d)
Initializes a new instance of the LinearDimension class
Top
Properties
  NameDescription
Public propertyAligned
Gets or sets a value indicating whether this annotation is aligned.
Public propertyAnnotationType
Public propertyArrowhead1End
Gets the arrow head end of the first extension line.
Public propertyArrowhead2End
Gets the arrow head end of the second extension line.
Public propertyDimensionLinePoint
Point on annotation plane where dimension line starts
Public propertyDistanceBetweenArrowTips
Gets the distance between arrow tips.
Public propertyExtensionLine1End
End of the first extension line.
Public propertyExtensionLine2End
End of the second extension line.
Public propertyNumericValue
Gets the numeric value (or measurement), depending on geometry type.

LinearDimension: distance between arrow tips

RadialDimension: radius or diameter depending on type

AngularDimension: angle in radians
Top
Methods
  NameDescription
Public methodStatic memberCreate
Initialize Dimension parameters
Public methodStatic memberFromPoints
Initializes a new instance of the LinearDimension class, based on three points.
Public methodGet3dPoints
Get locations of dimension's 3d points
Public methodGetDisplayLines
Public methodGetDistanceDisplayText
Public methodGetTextRectangle
Public methodSetLocations
Sets the three locations of the point, using two-dimensional points that refer to the plane of the annotation.
Top
See Also