LinearDimension Properties |
The LinearDimension type exposes the following members.
Name | Description | |
---|---|---|
Aligned |
Gets or sets a value indicating whether this annotation is aligned.
| |
AnnotationType | ||
Arrowhead1End |
Gets the arrow head end of the first extension line.
| |
Arrowhead2End |
Gets the arrow head end of the second extension line.
| |
DimensionLinePoint |
Point on annotation plane where dimension line starts
DimensionStyleId |
Id of this annotation's parent dimstyle
If this annotation has overrides to dimstyle properties,
those overrides will be represented in the DimensionStyle
Disposed |
Indicates if this object has been disposed or the
DistanceBetweenArrowTips |
Gets the distance between arrow tips.
| |
ExtensionLine1End |
End of the first extension line.
| |
ExtensionLine2End |
End of the second extension line.
| |
IsDeformable |
true if object can be accurately modified with "squishy" transformations like
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
MaskColor |
Color to use for drawing a text mask when it is enabled. If the mask is
enabled and MaskColor is System.Drawing.Color.Transparent, then the
MaskOffset |
Offset for the border around text of the rectangle used to draw the mask. This
value multiplied by TextHeight is the offset on each side of the tight rectangle
MaskUsesViewportColor |
If true, the viewport's color is used for the mask color. If
ObjectType |
Useful for switch statements that need to differentiate between
TextHeight |
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user