Click or drag to resize

AreaMassProperties Class

Contains static initialization methods and allows access to the computed metrics of area, area centroid and area moments in closed planar curves, in meshes, in surfaces, in hatches and in boundary representations.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryAreaMassProperties

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class AreaMassProperties : IDisposable

The AreaMassProperties type exposes the following members.

Properties
  NameDescription
Public propertyArea
Gets the area solution.
Public propertyAreaError
Gets the uncertainty in the area calculation.
Public propertyCentroid
Gets the area centroid in the world coordinate system.
Public propertyCentroidCoordinatesMomentsOfInertia
Moments of inertia with respect to centroid coordinate system. X = integral of ((y-y0)^2 + (z-z0)^2) dm Y = integral of ((z-z0)^2 + (x-x0)^2) dm Z = integral of ((z-z0)^2 + (y-y0)^2) dm where (x0,y0,z0) = centroid.
Public propertyCentroidCoordinatesMomentsOfInertiaError
Uncertainty in centroid coordinates moments of inertia calculation.
Public propertyCentroidCoordinatesProductMoments
Product moments with respect to centroid coordinate system.
Public propertyCentroidCoordinatesProductMomentsError
Uncertainty in product moments with respect to centroid coordinate system.
Public propertyCentroidCoordinatesRadiiOfGyration
Radii of gyration with respect to centroid coordinate system. X = sqrt(integral of ((y-y0)^2 + (z-z0)^2) dm/M) Y = sqrt(integral of ((z-z0)^2 + (x-x0)^2) dm/M) Z = sqrt(integral of ((z-z0)^2 + (y-y0)^2) dm/M) where (x0,y0,z0) = centroid.
Public propertyCentroidCoordinatesSecondMoments
Second moments with respect to centroid coordinate system. X = integral of (x-x0)^2 dm Y = integral of (y-y0)^2 dm Z = integral of (z-z0)^2 dm where (x0,y0,z0) = centroid.
Public propertyCentroidCoordinatesSecondMomentsError
Uncertainty in centroid coordinates second moments calculation.
Public propertyCentroidError
Gets the uncertainty in the centroid calculation.
Public propertyWorldCoordinatesFirstMoments
Returns the world coordinate first moments if they were able to be calculated. X is integral of "x dm" over the area Y is integral of "y dm" over the area Z is integral of "z dm" over the area.
Public propertyWorldCoordinatesFirstMomentsError
Uncertainty in world coordinates first moments calculation.
Public propertyWorldCoordinatesMomentsOfInertia
The moments of inertia about the world coordinate axes. X = integral of (y^2 + z^2) dm Y = integral of (z^2 + x^2) dm Z = integral of (z^2 + y^2) dm.
Public propertyWorldCoordinatesMomentsOfInertiaError
Uncertainty in world coordinates moments of inertia calculation.
Public propertyWorldCoordinatesProductMoments
Returns the world coordinate product moments if they were able to be calculated. X is integral of "xy dm" over the area Y is integral of "yz dm" over the area Z is integral of "zx dm" over the area.
Public propertyWorldCoordinatesProductMomentsError
Uncertainty in world coordinates second moments calculation.
Public propertyWorldCoordinatesRadiiOfGyration
Radii of gyration with respect to world coordinate system. X = sqrt(integral of (y^2 + z^2) dm/M) Y = sqrt(integral of (z^2 + x^2) dm/M) Z = sqrt(integral of (z^2 + y^2) dm/M)
Public propertyWorldCoordinatesSecondMoments
Returns the world coordinate second moments if they were able to be calculated. X is integral of "xx dm" over the area Y is integral of "yy dm" over the area Z is integral of "zz dm" over the area.
Public propertyWorldCoordinatesSecondMomentsError
Uncertainty in world coordinates second moments calculation.
Top
Methods
  NameDescription
Public methodCentroidCoordinatesPrincipalMoments
Calculates the eigenvalues and eigenvectors of the moments matrix with respect to centroid coordinates.
Public methodCentroidCoordinatesPrincipalMomentsOfInertia
Calculates the principal moments of inertia and principal axes with respect to centroid coordinates.
Public methodStatic memberCompute(Brep)
Computes an AreaMassProperties for a brep.
Public methodStatic memberCompute(Curve)
Computes an AreaMassProperties for a closed planar curve.
Public methodStatic memberCompute(Hatch)
Computes an AreaMassProperties for a hatch.
Public methodStatic memberCompute(IEnumerableGeometryBase)
Computes the Area properties for a collection of geometric objects. At present only Breps, Surfaces, Meshes and Planar Closed Curves are supported.
Public methodStatic memberCompute(Mesh)
Computes an AreaMassProperties for a mesh.
Public methodStatic memberCompute(Surface)
Computes an AreaMassProperties for a surface.
Public methodStatic memberCompute(Curve, Double)
Computes an AreaMassProperties for a closed planar curve.
Public methodStatic memberCompute(Brep, Boolean, Boolean, Boolean, Boolean)
Compute the AreaMassProperties for a single Brep.
Public methodStatic memberCompute(IEnumerableGeometryBase, Boolean, Boolean, Boolean, Boolean)
Computes the AreaMassProperties for a collection of geometric objects. At present only Breps, Surfaces, Meshes and Planar Closed Curves are supported.
Public methodStatic memberCompute(Mesh, Boolean, Boolean, Boolean, Boolean)
Compute the AreaMassProperties for a single Mesh.
Public methodStatic memberCompute(Surface, Boolean, Boolean, Boolean, Boolean)
Compute the AreaMassProperties for a single Surface.
Public methodStatic memberCompute(Brep, Boolean, Boolean, Boolean, Boolean, Double, Double)
Compute the AreaMassProperties for a single Brep.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodWorldCoordinatesPrincipalMoments
Calculates the eigenvalues and eigenvectors of moments matrix in world coordinates.
Public methodWorldCoordinatesPrincipalMomentsOfInertia
Calculates the principal moments of inertia and principal axes with respect to world coordinates.
Top
See Also