Click or drag to resize

AreaMassProperties Methods

The AreaMassProperties type exposes the following members.

Methods
  NameDescription
Public methodCentroidCoordinatesPrincipalMoments
Calculates the eigenvalues and eigenvectors of the moments matrix with respect to centroid coordinates.
Public methodCentroidCoordinatesPrincipalMomentsOfInertia
Calculates the principal moments of inertia and principal axes with respect to centroid coordinates.
Public methodStatic memberCompute(Brep)
Computes an AreaMassProperties for a brep.
Public methodStatic memberCompute(Curve)
Computes an AreaMassProperties for a closed planar curve.
Public methodStatic memberCompute(Hatch)
Computes an AreaMassProperties for a hatch.
Public methodStatic memberCompute(IEnumerableGeometryBase)
Computes the Area properties for a collection of geometric objects. At present only Breps, Surfaces, Meshes and Planar Closed Curves are supported.
Public methodStatic memberCompute(Mesh)
Computes an AreaMassProperties for a mesh.
Public methodStatic memberCompute(Surface)
Computes an AreaMassProperties for a surface.
Public methodStatic memberCompute(Curve, Double)
Computes an AreaMassProperties for a closed planar curve.
Public methodStatic memberCompute(Brep, Boolean, Boolean, Boolean, Boolean)
Compute the AreaMassProperties for a single Brep.
Public methodStatic memberCompute(IEnumerableGeometryBase, Boolean, Boolean, Boolean, Boolean)
Computes the AreaMassProperties for a collection of geometric objects. At present only Breps, Surfaces, Meshes and Planar Closed Curves are supported.
Public methodStatic memberCompute(Mesh, Boolean, Boolean, Boolean, Boolean)
Compute the AreaMassProperties for a single Mesh.
Public methodStatic memberCompute(Surface, Boolean, Boolean, Boolean, Boolean)
Compute the AreaMassProperties for a single Surface.
Public methodStatic memberCompute(Brep, Boolean, Boolean, Boolean, Boolean, Double, Double)
Compute the AreaMassProperties for a single Brep.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodWorldCoordinatesPrincipalMoments
Calculates the eigenvalues and eigenvectors of moments matrix in world coordinates.
Public methodWorldCoordinatesPrincipalMomentsOfInertia
Calculates the principal moments of inertia and principal axes with respect to world coordinates.
Top
See Also