Click or drag to resize

AreaMassPropertiesCompute Method (Surface)

Computes an AreaMassProperties for a surface.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static AreaMassProperties Compute(
	Surface surface
)

Parameters

surface
Type: Rhino.GeometrySurface
Surface to measure.

Return Value

Type: AreaMassProperties
The AreaMassProperties for the given Surface or null on failure.
Exceptions
ExceptionCondition
ArgumentNullExceptionWhen surface is null.
See Also