Click or drag to resize

AreaMassPropertiesCompute Method (Hatch)

Computes an AreaMassProperties for a hatch.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static AreaMassProperties Compute(
	Hatch hatch
)

Parameters

hatch
Type: Rhino.GeometryHatch
Hatch to measure.

Return Value

Type: AreaMassProperties
The AreaMassProperties for the given hatch or null on failure.
Exceptions
ExceptionCondition
ArgumentNullExceptionWhen hatch is null.
See Also