Click or drag to resize

AreaMassPropertiesCentroidCoordinatesPrincipalMoments Method

Calculates the eigenvalues and eigenvectors of the moments matrix with respect to centroid coordinates.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.9
Syntax
public bool CentroidCoordinatesPrincipalMoments(
	out double x,
	out Vector3d xaxis,
	out double y,
	out Vector3d yaxis,
	out double z,
	out Vector3d zaxis
)

Parameters

x
Type: SystemDouble
Principal moment.
xaxis
Type: Rhino.GeometryVector3d
Principal axis for x.
y
Type: SystemDouble
Principal moment.
yaxis
Type: Rhino.GeometryVector3d
Principal axis for y.
z
Type: SystemDouble
Principal moment.
zaxis
Type: Rhino.GeometryVector3d
Principal axis for z.

Return Value

Type: Boolean
true if successful.
See Also