Click or drag to resize

Box Structure

Represents the value of a plane and three intervals in an orthogonal, oriented box that is not necessarily parallel to the world Y, X, Z axes.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Box : IEpsilonComparable<Box>, ICloneable

The Box type exposes the following members.

Constructors
  NameDescription
Public methodBox(BoundingBox)
Initializes a new Box that mimics a BoundingBox struct.

The orientation plane of the Box is coincident with the World XY plane.

Public methodBox(Box)
Copy constructor.
Public methodBox(Plane, BoundingBox)
Initializes a world aligned box from a base plane and a bounding box.
Public methodBox(Plane, GeometryBase)
Initializes a box that contains a generic piece of geometry. This box will be aligned with an arbitrary plane.
Public methodBox(Plane, IEnumerablePoint3d)
Initializes the smallest box that contains a set of points.
Public methodBox(Plane, Interval, Interval, Interval)
Initializes a new box from a base Plane and three Intervals.
Top
Properties
  NameDescription
Public propertyArea
Gets the total surface area of this box.
Public propertyBoundingBox
Gets the world axis aligned Bounding box for this oriented box.
Public propertyCenter
Gets the point that is in the center of the box.
Public propertyStatic memberEmpty
Empty Box. Empty boxes are considered to be invalid.
Public propertyIsValid
Gets the validity of this Box. Boxes are invalid when the base plane or any of the dimension intervals are invalid or decreasing.
Public propertyPlane
Gets or sets the orientation plane for this Box.
Public propertyStatic memberUnset
Gets a Box whose base plane and axis dimensions are all Unset.
Public propertyVolume
Gets the total volume of this box.
Public propertyX
Gets or sets the Interval that describes the dimension of the Box along the orientation plane X-Axis. Otherwise known as the Width of the Box.
Public propertyY
Gets or sets the Interval that describes the dimension of the Box along the orientation plane Y-Axis. Otherwise known as the Depth of the Box.
Public propertyZ
Gets or sets the Interval that describes the dimension of the Box along the orientation plane Z-Axis. Otherwise known as the Height of the Box.
Top
Methods
  NameDescription
Public methodClosestPoint
Finds the closest point on or in the Box. The box should be Valid for this to work.
Public methodContains(BoundingBox)
Test a bounding box for Box inclusion. This is the same as calling Contains(box,false)
Public methodContains(Box)
Test a box for Box inclusion. This is the same as calling Contains(box,false)
Public methodContains(Point3d)
Determines whether a point is included in this box. This is the same as calling Contains(point,false)
Public methodContains(BoundingBox, Boolean)
Test a bounding box for Box inclusion.
Public methodContains(Box, Boolean)
Test a box for Box inclusion.
Public methodContains(Point3d, Boolean)
Determines whether a point is included in this box.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodFurthestPoint
Finds the furthest point on the Box. The Box should be Valid for this to work properly.
Public methodGetCorners
Gets an array of the 8 corner points of this box.
Public methodInflate(Double)
Inflates the box by a given offset in each direction. Inflating with negative amounts may result in decreasing boxes. InValid boxes cannot be inflated.
Public methodInflate(Double, Double, Double)
Inflates the box by a given offset in each direction. Inflating with negative amounts may result in decreasing boxes. InValid boxes cannot be inflated.
Public methodMakeValid
Attempts to make the Box valid. This is not always possible.
Public methodPointAt
Evaluates the box volume at the given unitized parameters.

The box has idealized side length of 1x1x1.

Public methodRepositionBasePlane
Repositions the origin of the Base plane for this box without affecting the physical dimensions.
Public methodToBrep
Constructs a brep representation of this box.
Public methodToExtrusion
Constructs an extrusion representation of this box.
Public methodTransform
Transforms this Box using a Transformation matrix. If the Transform does not preserve Similarity, the dimensions of the resulting box cannot be trusted.
Public methodUnion
Constructs a union between this Box and the given point. This grows the box in directions so it contains the point.
Top
See Also