Click or drag to resize

Box Methods

The Box type exposes the following members.

Methods
  NameDescription
Public methodClosestPoint
Finds the closest point on or in the Box. The box should be Valid for this to work.
Public methodContains(BoundingBox)
Test a bounding box for Box inclusion. This is the same as calling Contains(box,false)
Public methodContains(Box)
Test a box for Box inclusion. This is the same as calling Contains(box,false)
Public methodContains(Point3d)
Determines whether a point is included in this box. This is the same as calling Contains(point,false)
Public methodContains(BoundingBox, Boolean)
Test a bounding box for Box inclusion.
Public methodContains(Box, Boolean)
Test a box for Box inclusion.
Public methodContains(Point3d, Boolean)
Determines whether a point is included in this box.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodFurthestPoint
Finds the furthest point on the Box. The Box should be Valid for this to work properly.
Public methodGetCorners
Gets an array of the 8 corner points of this box.
Public methodInflate(Double)
Inflates the box by a given offset in each direction. Inflating with negative amounts may result in decreasing boxes. InValid boxes cannot be inflated.
Public methodInflate(Double, Double, Double)
Inflates the box by a given offset in each direction. Inflating with negative amounts may result in decreasing boxes. InValid boxes cannot be inflated.
Public methodMakeValid
Attempts to make the Box valid. This is not always possible.
Public methodPointAt
Evaluates the box volume at the given unitized parameters.

The box has idealized side length of 1x1x1.

Public methodRepositionBasePlane
Repositions the origin of the Base plane for this box without affecting the physical dimensions.
Public methodToBrep
Constructs a brep representation of this box.
Public methodToExtrusion
Constructs an extrusion representation of this box.
Public methodTransform
Transforms this Box using a Transformation matrix. If the Transform does not preserve Similarity, the dimensions of the resulting box cannot be trusted.
Public methodUnion
Constructs a union between this Box and the given point. This grows the box in directions so it contains the point.
Top
See Also