BoxContains Method (Box, Boolean) |
Test a box for Box inclusion.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Contains(
Box box,
bool strict
)
Public Function Contains (
box As Box,
strict As Boolean
) As Boolean
Parameters
- box
- Type: Rhino.GeometryBox
Box to test. - strict
- Type: SystemBoolean
If true, the box needs to be fully on the inside of this Box.
I.e. coincident boxes will be considered 'outside'.
Return Value
Type:
Booleantrue if the box is (strictly) on the inside of this Box.
See Also