BoxContains Method (BoundingBox, Boolean) |
Test a bounding box for Box inclusion.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Contains(
BoundingBox box,
bool strict
)
Public Function Contains (
box As BoundingBox,
strict As Boolean
) As Boolean
Parameters
- box
- Type: Rhino.GeometryBoundingBox
Box to test. - strict
- Type: SystemBoolean
If true, the bounding box needs to be fully on the inside of this Box.
I.e. coincident boxes will be considered 'outside'.
Return Value
Type:
Booleantrue if the box is (strictly) on the inside of this Box.
See Also