BoxContains Method (Point3d, Boolean) |
Determines whether a point is included in this box.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Contains(
Point3d point,
bool strict
)
Public Function Contains (
point As Point3d,
strict As Boolean
) As Boolean
Parameters
- point
- Type: Rhino.GeometryPoint3d
Point to test. - strict
- Type: SystemBoolean
If true, the point needs to be fully on the inside of the Box.
I.e. coincident points will be considered 'outside'.
Return Value
Type:
Booleantrue if the point is (strictly) on the inside of this Box.
See Also