Click or drag to resize

Box Properties

The Box type exposes the following members.

Properties
  NameDescription
Public propertyArea
Gets the total surface area of this box.
Public propertyBoundingBox
Gets the world axis aligned Bounding box for this oriented box.
Public propertyCenter
Gets the point that is in the center of the box.
Public propertyStatic memberEmpty
Empty Box. Empty boxes are considered to be invalid.
Public propertyIsValid
Gets the validity of this Box. Boxes are invalid when the base plane or any of the dimension intervals are invalid or decreasing.
Public propertyPlane
Gets or sets the orientation plane for this Box.
Public propertyStatic memberUnset
Gets a Box whose base plane and axis dimensions are all Unset.
Public propertyVolume
Gets the total volume of this box.
Public propertyX
Gets or sets the Interval that describes the dimension of the Box along the orientation plane X-Axis. Otherwise known as the Width of the Box.
Public propertyY
Gets or sets the Interval that describes the dimension of the Box along the orientation plane Y-Axis. Otherwise known as the Depth of the Box.
Public propertyZ
Gets or sets the Interval that describes the dimension of the Box along the orientation plane Z-Axis. Otherwise known as the Height of the Box.
Top
See Also