Click or drag to resize

HiddenLineDrawingObject Class

Represents an object added to a HiddenLineDrawing
Inheritance Hierarchy
SystemObject
  Rhino.GeometryHiddenLineDrawingObject

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class HiddenLineDrawingObject

The HiddenLineDrawingObject type exposes the following members.

Properties
  NameDescription
Public propertyGeometry
Returns the geometry in world coordinates if UseXform is false. Otherwise, the geometry in object space coordinates is returned.
Public propertyOccludingSections
Objects in this drawing could have occluding sections. Objects must added with the occluding section option set as desired.
Public propertyTag
Returns the extra data used to cross-reference the object specified in HiddenLineDrawing.AddObject.
Public propertyTransform
Returns the transformation passed into the Add... function when setting up the hidden line drawing parameters.
Top
Methods
  NameDescription
Top
See Also