Click or drag to resize

Polyline Class

Represents an ordered set of points connected by linear segments.

Polylines are closed if start and end points coincide.

Inheritance Hierarchy
SystemObject
  Rhino.CollectionsRhinoListPoint3d
    Rhino.CollectionsPoint3dList
      Rhino.GeometryPolyline

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class Polyline : Point3dList, ICloneable

The Polyline type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyIsClosed
Test a polyline to see if it is closed.
Public propertyIsValid
Gets a value that indicates whether this polyline is valid.

Valid polylines have at least one segment, no Invalid points and no zero length segments.

Closed polylines with only two segments are also not considered valid.

Public propertyLength
Gets the total length of the polyline.
Public propertySegmentCount
Gets the number of segments for this polyline.
Top
Methods
  NameDescription
Public methodBreakAtAngles
Breaks this polyline into sections at sharp kinks. Closed polylines will also be broken at the first and last vertex.
Public methodCenterPoint
Compute the center point of the polyline as the weighted average of all segments.
Public methodClosestParameter
Gets the parameter along the polyline which is closest to a test-point.
Public methodClosestPoint
Gets the point on the polyline which is closest to a test-point.
Public methodCollapseShortSegments
Collapses all segments until none are shorter than tolerance. This function is significantly slower than DeleteShortSegments, since it recursively operates on the shortest segment. When a segment is collapsed the end-points are placed in the center of the segment.
Public methodStatic memberCreateByJoiningLines
Creates polylines by joining lines.
Public methodStatic memberCreateCircumscribedPolygon
Create a regular polygon circumscribe about a circle. The midpoints of the polygon's edges will be tangent to the circle.
Public methodStatic memberCreateInscribedPolygon
Create a regular polygon inscribed in a circle. The vertices of the polygon will be on the circle.
Public methodStatic memberCreateStarPolygon
Create a regular star polygon. The star begins at circle.PointAt(0) and the vertices alternate between being on circle and begin on a concentric circle of other_radius.
Public methodDeleteShortSegments
Removes all points that are closer than tolerance to the previous point.

Start and end points are left intact.

Public methodDuplicate
Returns a deep copy of this polyline instance.
Public methodGetSegments
Constructs an array of line segments that make up the entire polyline.
Public methodIsClosedWithinTolerance
Test a polyline to see if it is closed.
Public methodMergeColinearSegments
Merge co-linear consecutive segments in a polyline. This method will automatically remove any zero-length segments as well.
Public methodPointAt
Gets the point on the polyline at the given parameter. The integer part of the parameter indicates the index of the segment.
Public methodReduceSegments
Constructs a reduction of this polyline by recursively removing the least significant segments.
Public methodRemoveNearlyEqualSubsequentPoints
Removes one copy of a point that is equal to the previous or later point, by an absolute tolerance factor.
Public methodSegmentAt
Gets the line segment at the given index.
Public methodSmooth
Smoothen the polyline segments by averaging adjacent vertices. Smoothing requires a polyline with exclusively valid vertices.
Public methodTangentAt
Gets the unit tangent vector along the polyline at the given parameter. The integer part of the parameter indicates the index of the segment.
Public methodToNurbsCurve
Constructs a nurbs curve representation of this polyline.
Public methodToPolylineCurve
Constructs a polyline curve representation of this polyline.
Public methodTriangulateClosedPolyline
Attempts to create a list of triangles which represent a triangulation of a closed polyline
Public methodTrim
Constructs a polyline out of a parameter sub-domain in this curve.
Top
See Also