Click or drag to resize

RhinoListTFindIndex Method (PredicateT)

Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List.

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public int FindIndex(
	Predicate<T> match
)

Parameters

match
Type: SystemPredicateT
The Predicate(T) delegate that defines the conditions of the element to search for.

Return Value

Type: Int32
The zero-based index of the first occurrence of an element that matches the conditions defined by match, if found; otherwise, -1.
See Also