Click or drag to resize

RhinoListT Methods

The RhinoListT generic type exposes the following members.

Methods
  NameDescription
Public methodAdd
Adds an object to the end of the List.
Public methodAddRange(IEnumerable)
Adds the elements of the specified collection to the end of the List.
Public methodAddRange(IEnumerableT)
Adds the elements of the specified collection to the end of the List.
Public methodAsReadOnly
Constructs a read-only wrapper of this class.
Public methodBinarySearch(T)
Searches the entire sorted List for an element using the default comparer and returns the zero-based index of the element.
Public methodBinarySearch(T, IComparerT)
Searches the entire sorted List for an element using the specified comparer and returns the zero-based index of the element.
Public methodBinarySearch(Int32, Int32, T, IComparerT)
Searches the entire sorted List for an element using the specified comparer and returns the zero-based index of the element.
Public methodClear
Removes all elements from the List.
Public methodContains
Determines whether an element is in the List.
Public methodConvertAllTOutput
Aggregates all results of a conversion function over this table into a new list.
Public methodCopyTo(T)
Copies the entire List to a compatible one-dimensional array, starting at the beginning of the target array.
Public methodCopyTo(T, Int32)
Copies the entire List to a compatible one-dimensional array, starting at the specified index of the target array.
Public methodCopyTo(Int32, T, Int32, Int32)
Copies a range of elements from the List to a compatible one-dimensional array, starting at the specified index of the target array.
Public methodDuplicate
Returns a shallow copy of this instance. If the generic type is comprised of only value types (struct, enum, ptr), then the result will be a deep copy.
Public methodExists
Determines whether the List contains elements that match the conditions defined by the specified predicate.
Public methodFind
Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List.
Public methodFindAll
Retrieves all the elements that match the conditions defined by the specified predicate.
Public methodFindIndex(PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List.
Public methodFindIndex(Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List.
Public methodFindIndex(Int32, Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List that extends from the specified index to the last element.
Public methodFindLast
Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List.
Public methodFindLastIndex(PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List.
Public methodFindLastIndex(Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List.
Public methodFindLastIndex(Int32, Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List.
Public methodForEach
Performs the specified action on each element of the List.
Public methodGetEnumerator
Constructs an enumerator that is capable of iterating over all items in this list.
Public methodGetRange
Constructs a shallow copy of a range of elements in the source List.
Public methodIndexOf(T)
Searches for the specified object and returns the zero-based index of the first occurrence within the entire List.
Public methodIndexOf(T, Int32)
Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List that extends from the specified index to the last element.
Public methodIndexOf(T, Int32, Int32)
Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List that starts at the specified index and contains the specified number of elements.
Public methodInsert
Inserts an element into the List at the specified index.
Public methodInsertRange
Inserts the elements of a collection into the List at the specified index.
Public methodLastIndexOf(T)
Searches for the specified object and returns the zero-based index of the last occurrence within the entire List.
Public methodLastIndexOf(T, Int32)
Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List that extends from the first element to the specified index.
Public methodLastIndexOf(T, Int32, Int32)
Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List that contains the specified number of elements and ends at the specified index.
Public methodRemapIndex
Remap an index in the infinite range onto the List index range.
Public methodRemove
Removes the first occurrence of a specific object from the List.
Public methodRemoveAll
Removes the all the elements that match the conditions defined by the specified predicate.
Public methodRemoveAt
Removes the element at the specified index of the List.
Public methodRemoveNulls
Removes all elements from the List that are null references (Nothing in Visual Basic). This function will not do anything if T is not a Reference type.
Public methodRemoveRange
Removes a range of elements from the List.
Public methodReverse
Reverses the order of the elements in the entire List.
Public methodReverse(Int32, Int32)
Reverses the order of the elements in the specified range.
Public methodSort
Sorts the elements in the entire List using the default comparer.
Public methodSort(ComparisonT)
Sorts the elements in the entire list using the specified comparer.
Public methodSort(Double)
Sort this list based on a list of numeric keys of equal length. The keys array will not be altered.
Public methodSort(IComparerT)
Sorts the elements in the entire list using the specified System.Comparison(T)
Public methodSort(Int32)
Sort this list based on a list of numeric keys of equal length. The keys array will not be altered.
Public methodSort(Int32, Int32, IComparerT)
Sorts the elements in a range of elements in list using the specified comparer.
Public methodToArray
Constructs an array that contains all items in this list.
Public methodTrimExcess
Sets the capacity to the actual number of elements in the List, if that number is less than a threshold value.
Public methodTrueForAll
Determines whether every element in the List matches the conditions defined by the specified predicate.
Top
See Also