Retrieves all the elements that match the conditions defined by the specified predicate.
Namespace:
Rhino.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Syntax public RhinoList<T> FindAll(
Predicate<T> match
)
Public Function FindAll (
match As Predicate(Of T)
) As RhinoList(Of T)
Parameters
- match
- Type: SystemPredicateT
The Predicate(T) delegate that defines the conditions of the elements to search for.
Return Value
Type:
RhinoListTA ON_List(T) containing all the elements that match the conditions
defined by the specified predicate, if found; otherwise, an empty ON_List(T).
See Also