PolylineDeleteShortSegments Method |
Removes all points that are closer than tolerance to the previous point.
Start and end points are left intact.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int DeleteShortSegments(
double tolerance
)
Public Function DeleteShortSegments (
tolerance As Double
) As Integer
Parameters
- tolerance
- Type: SystemDouble
Vertices closer together than tolerance will be removed.
Return Value
Type:
Int32Number of points (and segments) removed.
See Also