PolylineCollapseShortSegments Method |
Collapses all segments until none are shorter than tolerance.
This function is significantly slower than DeleteShortSegments,
since it recursively operates on the shortest segment.
When a segment is collapsed the end-points are placed in the center of the segment.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int CollapseShortSegments(
double tolerance
)
Public Function CollapseShortSegments (
tolerance As Double
) As Integer
Parameters
- tolerance
- Type: SystemDouble
Tolerance to use during collapsing.
Return Value
Type:
Int32The number of segments that were collapsed.
See Also