Click or drag to resize

PolylineReduceSegments Method

Constructs a reduction of this polyline by recursively removing the least significant segments.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int ReduceSegments(
	double tolerance
)

Parameters

tolerance
Type: SystemDouble
Tolerance for reduction. Whenever a vertex of the polyline is more significant than tolerance, it will be included in the reduction.

Return Value

Type: Int32
The number of vertices that disappeared due to reduction.
See Also