Click or drag to resize

PolylineIsClosedWithinTolerance Method

Test a polyline to see if it is closed.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool IsClosedWithinTolerance(
	double tolerance
)

Parameters

tolerance
Type: SystemDouble
The tolerance.

Return Value

Type: Boolean
Returns true if polyline has 4 or more points, the distance between the start and end points is <= tolerance, and there is a point in the polyline whose distance from the start and end points is > tolerance.
See Also