Smoothen the polyline segments by averaging adjacent vertices.
Smoothing requires a polyline with exclusively valid vertices.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Smooth(
double amount
)
Public Function Smooth (
amount As Double
) As Boolean
Parameters
- amount
- Type: SystemDouble
Amount to smooth. Zero equals no smoothing, one equals complete smoothing.
Return Value
Type:
Booleantrue on success, false on failure.
See Also