Polyline Methods |
The Polyline type exposes the following members.
Name | Description | |
---|---|---|
BinarySearch(T) |
Searches the entire sorted List for an element using the default comparer
BinarySearch(T, IComparerT) |
Searches the entire sorted List for an element using the specified
BinarySearch(Int32, Int32, T, IComparerT) |
Searches the entire sorted List for an element using the specified
BreakAtAngles |
Breaks this polyline into sections at sharp kinks.
Closed polylines will also be broken at the first and last vertex.
| |
CenterPoint |
Compute the center point of the polyline as the weighted average of all segments.
ClosestParameter |
Gets the parameter along the polyline which is closest to a test-point.
| |
ClosestPoint |
Gets the point on the polyline which is closest to a test-point.
| |
CollapseShortSegments |
Collapses all segments until none are shorter than tolerance.
This function is significantly slower than DeleteShortSegments,
since it recursively operates on the shortest segment.
When a segment is collapsed the end-points are placed in the center of the segment.
CopyTo(T) |
Copies the entire List to a compatible one-dimensional array,
CopyTo(T, Int32) |
Copies the entire List to a compatible one-dimensional array,
CopyTo(Int32, T, Int32, Int32) |
Copies a range of elements from the List to a compatible one-dimensional array,
CreateByJoiningLines |
Creates polylines by joining lines.
| |
CreateCircumscribedPolygon |
Create a regular polygon circumscribe about a circle. The midpoints of the polygon's edges will be tangent to the circle.
| |
CreateInscribedPolygon |
Create a regular polygon inscribed in a circle. The vertices of the polygon will be on the circle.
| |
CreateStarPolygon |
Create a regular star polygon. The star begins at circle.PointAt(0) and the vertices
alternate between being on circle and begin on a concentric circle of other_radius.
| |
DeleteShortSegments |
Removes all points that are closer than tolerance to the previous point.
Start and end points are left intact. | |
Duplicate |
Returns a deep copy of this polyline instance.
Exists |
Determines whether the List contains elements that match the
Find |
Searches for an element that matches the conditions defined by the
FindIndex(PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the first
FindIndex(Int32, PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the first
FindIndex(Int32, Int32, PredicateT) |
Searches for an element that matches the conditions defined by the specified predicate,
and returns the zero-based index of the first occurrence within the range of elements
FindLast |
Searches for an element that matches the conditions defined by the
FindLastIndex(PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the last
FindLastIndex(Int32, PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the last
FindLastIndex(Int32, Int32, PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the last
GetSegments |
Constructs an array of line segments that make up the entire polyline.
| |
IndexOf(T) |
Searches for the specified object and returns the zero-based index of the
IndexOf(T, Int32) |
Searches for the specified object and returns the zero-based index of
the first occurrence within the range of elements in the List that
IndexOf(T, Int32, Int32) |
Searches for the specified object and returns the zero-based index of the first
occurrence within the range of elements in the List that starts at the specified
IsClosedWithinTolerance |
Test a polyline to see if it is closed.
LastIndexOf(T, Int32) |
Searches for the specified object and returns the zero-based index
of the last occurrence within the range of elements in the List
LastIndexOf(T, Int32, Int32) |
Searches for the specified object and returns the zero-based index of the
last occurrence within the range of elements in the List that contains
MergeColinearSegments |
Merge co-linear consecutive segments in a polyline.
This method will automatically remove any zero-length segments as well.
| |
PointAt |
Gets the point on the polyline at the given parameter.
The integer part of the parameter indicates the index of the segment.
| |
ReduceSegments |
Constructs a reduction of this polyline by recursively removing the least significant segments.
RemoveNearlyEqualSubsequentPoints |
Removes one copy of a point that is equal to the previous or later point, by an absolute tolerance factor.
SegmentAt |
Gets the line segment at the given index.
Smooth |
Smoothen the polyline segments by averaging adjacent vertices.
Smoothing requires a polyline with exclusively valid vertices.
Sort(Double) |
Sort this list based on a list of numeric keys of equal length.
Sort(Int32) |
Sort this list based on a list of numeric keys of equal length.
TangentAt |
Gets the unit tangent vector along the polyline at the given parameter.
The integer part of the parameter indicates the index of the segment.
ToNurbsCurve |
Constructs a nurbs curve representation of this polyline.
| |
ToPolylineCurve |
Constructs a polyline curve representation of this polyline.
| |
TriangulateClosedPolyline |
Attempts to create a list of triangles which represent a
triangulation of a closed polyline
| |
Trim |
Constructs a polyline out of a parameter sub-domain in this curve.