Click or drag to resize

Point3dList Class

Represents a list of Point3d.
Inheritance Hierarchy
SystemObject
  Rhino.CollectionsRhinoListPoint3d
    Rhino.CollectionsPoint3dList
      Rhino.GeometryPolyline

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class Point3dList : RhinoList<Point3d>, 
	ICloneable, IEquatable<Point3dList>

The Point3dList type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyBoundingBox
Even though this is a property, it is not a "fast" calculation. Every point is evaluated in order to get the bounding box of the list.
Public propertyX
Returns an indexer with all X coordinates in this list.
Public propertyY
Returns an indexer with all Y coordinates in this list.
Public propertyZ
Returns an indexer with all Z coordinates in this list.
Top
Methods
  NameDescription
Public methodCode exampleAdd(Double, Double, Double)
Adds a Point3d to the end of the list with given x,y,z coordinates.
Public methodClosestIndex
Finds the index of the point that is closest to a test point in this list.
Public methodStatic memberClosestIndexInList
Finds the index of the point in a list of points that is closest to a test point.
Public methodStatic memberClosestPointInList
Finds the point in a list of points that is closest to a test point.
Public methodDuplicate
Returns a deep copy of this point list instance.
Public methodEquals(Object)
Overrides the default object equality to compare lists by value.
(Overrides ObjectEquals(Object).)
Public methodEquals(Point3dList)
Determines if the point lists are exactly equal.
Public methodGetHashCode
Creates a hash code for this object.
(Overrides ObjectGetHashCode.)
Public methodSetAllX
Set all the X values for the points to a single value
Public methodSetAllY
Set all the Y values for the points to a single value
Public methodSetAllZ
Set all the Z values for the points to a single value
Public methodTransform
Applies a transform to all the points in the list.
Top
See Also