Point3dList Methods |
The Point3dList type exposes the following members.
Name | Description | |
---|---|---|
![]() | Add(T) |
Adds an object to the end of the List.
(Inherited from RhinoListT.) |
![]() ![]() | Add(Double, Double, Double) |
Adds a Point3d to the end of the list with given x,y,z coordinates.
|
![]() | AddRange(IEnumerable) |
Adds the elements of the specified collection to the end of the List.
(Inherited from RhinoListT.) |
![]() | AddRange(IEnumerableT) |
Adds the elements of the specified collection to the end of the List.
(Inherited from RhinoListT.) |
![]() | AsReadOnly |
Constructs a read-only wrapper of this class.
(Inherited from RhinoListT.) |
![]() | BinarySearch(T) |
Searches the entire sorted List for an element using the default comparer
and returns the zero-based index of the element.
(Inherited from RhinoListT.) |
![]() | BinarySearch(T, IComparerT) |
Searches the entire sorted List for an element using the specified
comparer and returns the zero-based index of the element.
(Inherited from RhinoListT.) |
![]() | BinarySearch(Int32, Int32, T, IComparerT) |
Searches the entire sorted List for an element using the specified
comparer and returns the zero-based index of the element.
(Inherited from RhinoListT.) |
![]() | Clear |
Removes all elements from the List.
(Inherited from RhinoListT.) |
![]() | ClosestIndex |
Finds the index of the point that is closest to a test point in this list.
|
![]() ![]() | ClosestIndexInList |
Finds the index of the point in a list of points that is closest to a test point.
|
![]() ![]() | ClosestPointInList |
Finds the point in a list of points that is closest to a test point.
|
![]() | Contains |
Determines whether an element is in the List.
(Inherited from RhinoListT.) |
![]() | ConvertAllTOutput |
Aggregates all results of a conversion function over this table into a new list.
(Inherited from RhinoListT.) |
![]() | CopyTo(T) |
Copies the entire List to a compatible one-dimensional array,
starting at the beginning of the target array.
(Inherited from RhinoListT.) |
![]() | CopyTo(T, Int32) |
Copies the entire List to a compatible one-dimensional array,
starting at the specified index of the target array.
(Inherited from RhinoListT.) |
![]() | CopyTo(Int32, T, Int32, Int32) |
Copies a range of elements from the List to a compatible one-dimensional array,
starting at the specified index of the target array.
(Inherited from RhinoListT.) |
![]() | Duplicate |
Returns a deep copy of this point list instance.
|
![]() | Equals(Object) |
Overrides the default object equality to compare lists by value.
(Overrides ObjectEquals(Object).) |
![]() | Equals(Point3dList) |
Determines if the point lists are exactly equal.
|
![]() | Exists |
Determines whether the List contains elements that match the
conditions defined by the specified predicate.
(Inherited from RhinoListT.) |
![]() | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) |
![]() | Find |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the first occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | FindAll |
Retrieves all the elements that match the conditions defined by the specified predicate.
(Inherited from RhinoListT.) |
![]() | FindIndex(PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the first
occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | FindIndex(Int32, PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the first
occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | FindIndex(Int32, Int32, PredicateT) |
Searches for an element that matches the conditions defined by the specified predicate,
and returns the zero-based index of the first occurrence within the range of elements
in the List that extends from the specified index to the last element.
(Inherited from RhinoListT.) |
![]() | FindLast |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the last occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | FindLastIndex(PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the last
occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | FindLastIndex(Int32, PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the last
occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | FindLastIndex(Int32, Int32, PredicateT) |
Searches for an element that matches the conditions defined by the
specified predicate, and returns the zero-based index of the last
occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | ForEach |
Performs the specified action on each element of the List.
(Inherited from RhinoListT.) |
![]() | GetEnumerator |
Constructs an enumerator that is capable of iterating over all items in this list.
(Inherited from RhinoListT.) |
![]() | GetHashCode |
Creates a hash code for this object.
(Overrides ObjectGetHashCode.) |
![]() | GetRange |
Constructs a shallow copy of a range of elements in the source List.
(Inherited from RhinoListT.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | IndexOf(T) |
Searches for the specified object and returns the zero-based index of the
first occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | IndexOf(T, Int32) |
Searches for the specified object and returns the zero-based index of
the first occurrence within the range of elements in the List that
extends from the specified index to the last element.
(Inherited from RhinoListT.) |
![]() | IndexOf(T, Int32, Int32) |
Searches for the specified object and returns the zero-based index of the first
occurrence within the range of elements in the List that starts at the specified
index and contains the specified number of elements.
(Inherited from RhinoListT.) |
![]() | Insert |
Inserts an element into the List at the specified index.
(Inherited from RhinoListT.) |
![]() | InsertRange |
Inserts the elements of a collection into the List at the specified index.
(Inherited from RhinoListT.) |
![]() | LastIndexOf(T) |
Searches for the specified object and returns the zero-based
index of the last occurrence within the entire List.
(Inherited from RhinoListT.) |
![]() | LastIndexOf(T, Int32) |
Searches for the specified object and returns the zero-based index
of the last occurrence within the range of elements in the List
that extends from the first element to the specified index.
(Inherited from RhinoListT.) |
![]() | LastIndexOf(T, Int32, Int32) |
Searches for the specified object and returns the zero-based index of the
last occurrence within the range of elements in the List that contains
the specified number of elements and ends at the specified index.
(Inherited from RhinoListT.) |
![]() | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) |
![]() | RemapIndex |
Remap an index in the infinite range onto the List index range.
(Inherited from RhinoListT.) |
![]() | Remove |
Removes the first occurrence of a specific object from the List.
(Inherited from RhinoListT.) |
![]() | RemoveAll |
Removes the all the elements that match the conditions defined by the specified predicate.
(Inherited from RhinoListT.) |
![]() | RemoveAt |
Removes the element at the specified index of the List.
(Inherited from RhinoListT.) |
![]() | RemoveNulls |
Removes all elements from the List that are null references (Nothing in Visual Basic).
This function will not do anything if T is not a Reference type.
(Inherited from RhinoListT.) |
![]() | RemoveRange |
Removes a range of elements from the List.
(Inherited from RhinoListT.) |
![]() | Reverse |
Reverses the order of the elements in the entire List.
(Inherited from RhinoListT.) |
![]() | Reverse(Int32, Int32) |
Reverses the order of the elements in the specified range.
(Inherited from RhinoListT.) |
![]() | SetAllX |
Set all the X values for the points to a single value
|
![]() | SetAllY |
Set all the Y values for the points to a single value
|
![]() | SetAllZ |
Set all the Z values for the points to a single value
|
![]() | Sort |
Sorts the elements in the entire List using the default comparer.
(Inherited from RhinoListT.) |
![]() | Sort(ComparisonT) |
Sorts the elements in the entire list using the specified comparer.
(Inherited from RhinoListT.) |
![]() | Sort(Double) |
Sort this list based on a list of numeric keys of equal length.
The keys array will not be altered.
(Inherited from RhinoListT.) |
![]() | Sort(IComparerT) |
Sorts the elements in the entire list using the specified System.Comparison(T)
(Inherited from RhinoListT.) |
![]() | Sort(Int32) |
Sort this list based on a list of numeric keys of equal length.
The keys array will not be altered.
(Inherited from RhinoListT.) |
![]() | Sort(Int32, Int32, IComparerT) |
Sorts the elements in a range of elements in list using the specified comparer.
(Inherited from RhinoListT.) |
![]() | ToArray |
Constructs an array that contains all items in this list.
(Inherited from RhinoListT.) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![]() | Transform |
Applies a transform to all the points in the list.
|
![]() | TrimExcess |
Sets the capacity to the actual number of elements in the List,
if that number is less than a threshold value.
(Inherited from RhinoListT.) |
![]() | TrueForAll |
Determines whether every element in the List matches the conditions defined by the specified predicate.
(Inherited from RhinoListT.) |