Point3dListClosestIndexInList Method |
Finds the index of the point in a list of points that is closest to a test point.
Namespace:
Rhino.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static int ClosestIndexInList(
IList<Point3d> list,
Point3d testPoint
)
Public Shared Function ClosestIndexInList (
list As IList(Of Point3d),
testPoint As Point3d
) As Integer
Parameters
- list
- Type: System.Collections.GenericIListPoint3d
A list of points. - testPoint
- Type: Rhino.GeometryPoint3d
Point to compare against.
Return Value
Type:
Int32Index of closest point in the list on success or -1 on error.
See Also