Click or drag to resize

Particle Class

Represents a simple particle.

This base class only defines position and display properties (size, color, bitmap id). You will most likely create a class that derives from this particle class to perform some sort of physical simulation (movement over time or frames).

Inheritance Hierarchy
SystemObject
  Rhino.GeometryParticle

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Particle

The Particle type exposes the following members.

Constructors
  NameDescription
Public methodParticle
Initializes a new instance of the Particle class.
Top
Properties
  NameDescription
Public propertyColor
Public propertyDisplayBitmapIndex
Public propertyIndex
Index in ParentSystem for this Particle. Can change when the particle system is modified.
Public propertyLocation
3d Location of the Particle.
Public propertyParentSystem
Gets the parent particle system of this particle.
Public propertySize
Top
Methods
  NameDescription
Public methodUpdate
Base class implementation does nothing.
Top
See Also