Click or drag to resize

Light Class

Represents a light that shines in the modeling space.
Inheritance Hierarchy

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class Light : GeometryBase

The Light type exposes the following members.

Constructors
  NameDescription
Public methodLight
Initializes a new light.
Protected methodLight(SerializationInfo, StreamingContext)
Protected constructor used in serialization.
Top
Properties
  NameDescription
Public propertyAmbient
Gets or sets the ambient color.
Public propertyAttenuationType
Get the type of attenuation for this light.
Public propertyAttenuationVector
Gets or Sets the attenuation vector.
Public propertyCoordinateSystem
Gets a value, determined by LightStyle, that explains whether the camera directions are relative to World or Camera spaces.
Public propertyCode exampleDiffuse
Gets or sets the diffuse color.
Public propertyDirection
Gets or sets the vector direction of the camera.
Public propertyHotSpot
The hot spot setting runs from 0.0 to 1.0 and is used to provides a linear interface for controlling the focus or concentration of a spotlight. A hot spot setting of 0.0 corresponds to a spot exponent of 128. A hot spot setting of 1.0 corresponds to a spot exponent of 0.0.
Public propertyId
Gets the ID of this light.
Public propertyIntensity
Gets or sets the light intensity.
Public propertyIsDirectionalLight
Gets a value indicating whether the light style is LightStyle CameraDirectional or WorldDirectional.
Public propertyIsEnabled
Gets or sets a value that defines if the light is turned on (true) or off (false).
Public propertyIsLinearLight
Gets a value indicating whether the light style is LightStyle WorldLinear.
Public propertyIsPointLight
Gets a value indicating whether the light style is LightStyle CameraPoint or WorldPoint.
Public propertyIsRectangularLight
Gets a value indicating whether the light style is LightStyle WorldRectangular.
Public propertyIsSpotLight
Gets a value indicating whether the light style is LightStyle CameraSpot or WorldSpot.
Public propertyIsSunLight
Gets a value indicating whether this object is a Sun light.
Public propertyLength
Gets or sets the height in linear and rectangular lights.

(ignored for non-linear/rectangular lights.)

Public propertyLightStyle
Gets or sets a light style on this camera.
Public propertyLocation
Gets or sets the light or 3D position or location.
Public propertyName
Gets or sets the spot light name.
Public propertyPerpendicularDirection
Gets a perpendicular vector to the camera direction.
Public propertyPowerCandela
Gets or sets the light power in candelas (cd).
Public propertyPowerLumens
Gets or sets the light power in lumens (lm).
Public propertyPowerWatts
Gets or sets the light power in watts (W).
Public propertyShadowIntensity
Gets or sets the shadow intensity for the light.
Public propertySpecular
Gets or sets the specular color.
Public propertySpotAngleRadians
Gets or sets the spot angle in radians.

Ignored for non-spot lights.

angle = 0 to pi/2 (0 to 90 degrees).

Public propertySpotExponent
The spot exponent varies from 0.0 to 128.0 and provides an exponential interface for controlling the focus or concentration of a spotlight (like the OpenGL GL_SPOT_EXPONENT parameter). The spot exponent and hot spot parameters are linked; changing one will change the other. A hot spot setting of 0.0 corresponds to a spot exponent of 128. A hot spot setting of 1.0 corresponds to a spot exponent of 0.0.
Public propertySpotLightShadowIntensity Obsolete.
Gets or sets the spot light shadow intensity.

(ignored for non-spot lights.)

Public propertyWidth
Gets or sets the width in linear and rectangular lights.

(ignored for non-linear/rectangular lights.)

Top
Methods
  NameDescription
Public methodStatic memberCreateSunLight(Sun)
Constructs a light which simulates a Sun.
Public methodStatic memberCreateSunLight(Double, Double, Double)
Constructs a light that represents the Sun.
Public methodStatic memberCreateSunLight(Double, DateTime, Double, Double)
Constructs a light which simulates the Sun based on a given time and location on Earth.
Public methodGetAttenuation
Gets the attenuation settings (ignored for "directional" and "ambient" lights).

attenuation = 1/(a0 + d*a1 + d^2*a2) where d = distance to light.

Public methodGetSpotLightRadii
Gets the spot light radii.
Public methodSetAttenuation
Sets the attenuation settings (ignored for "directional" and "ambient" lights).

attenuation = 1/(a0 + d*a1 + d^2*a2) where d = distance to light.

Top
Fields
  NameDescription
Public fieldStatic memberConstantAttenuationVector
Vector denoting a constant light attenuation.
Public fieldStatic memberInverseSquaredAttenuationVector
Vector denoting an inverse squared light attenuation.
Public fieldStatic memberLinearAttenuationVector
Vector denoting a linear light attenuation.
Top
See Also