LightGetAttenuation Method |
Gets the attenuation settings (ignored for "directional" and "ambient" lights).
attenuation = 1/(a0 + d*a1 + d^2*a2) where d = distance to light.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public double GetAttenuation(
double d
)
Public Function GetAttenuation (
d As Double
) As Double
Parameters
- d
- Type: SystemDouble
The distance to evaluate.
Return Value
Type:
Double0 if a0 + d*a1 + d^2*a2 <= 0.
See Also