Click or drag to resize

ShrinkWrapParameters Class

Parameters for ShrinkWrap method
Inheritance Hierarchy
SystemObject
  Rhino.GeometryShrinkWrapParameters

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public class ShrinkWrapParameters

The ShrinkWrapParameters type exposes the following members.

Constructors
  NameDescription
Public methodShrinkWrapParameters
Initializes a new instance of the ShrinkWrapParameters class
Top
Properties
  NameDescription
Public propertyFillHolesInInputObjects
Any input meshes will have "Fill Holes" applied to them before volume creation This value is ignored when input objects are Point Clouds
Public propertyInflateVerticesAndPoints
Inflate mesh vertices, points and point clouds Mesh vertices will be inflated as though the mesh were a point cloud
Public propertyOffset
Distance to offset outward or inward
Public propertyPolygonOptimization
0 - 100 the percentage of optimization desired. Polygons will be reduced in areas of lower curvature Lower values result in better feature preservation at the cost of more polygons
Public propertySmoothingIterations
Number of times to apply smoothing
Public propertyTargetEdgeLength
The desired target edge length in document units Smaller values equal more mesh resolution at the expense of larger mesh sizes
Top
Methods
  NameDescription
Top
See Also