Click or drag to resize

Squisher Class

class used to wrap Squish functions
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySquisher

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Squisher : IDisposable

The Squisher type exposes the following members.

Constructors
  NameDescription
Public methodSquisher
constructs a squisher with default parameters
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGet2dMesh
Get the 2d mesh that results from the squish operation
Public methodGet3dMesh
Get the 3d mesh that was used for squish operation
Public methodGetAreaConstrainedTrianglesIndices
Gets mesh vertex indices for the triangular faces that were constrained during the squish. Indices can be used in both the 2d and 3d mesh vertices arrays.
Public methodGetLengthConstrained2dLines
Gets lines at the position of the mesh edges and diagonals that were constrained during the squish, in the 2d mesh. The line at any index here corresponds to the same line in GetLengthConstrained3dLines.
Public methodGetLengthConstrained3dLines
Gets lines at the position of the mesh edges and diagonals that were constrained during the squish, in the 3d mesh. The line at any index here corresponds to the same line in GetLengthConstrained2dLines.
Public methodGetMesh2dEdges
Gets lines at the position of the mesh edges and diagonals that were constrained during the squish, in the 2d mesh. The line at any index here corresponds to the same line in GetLengthConstrained3dLines.
Public methodGetMesh3dEdges
Gets lines at the position of the mesh edges and diagonals that were constrained during the squish, in the 3d mesh. The line at any index here corresponds to the same line in GetLengthConstrained2dLines.
Public methodStatic memberIs2dPatternSquished
Returns true if the input geometry was the result of a squish operation
Public methodStatic memberSquishBack2dMarks
Maps 2D geometry from the squished surface or mesh back to the original 3D surface or mesh
Public methodSquishCurve
Maps a curve on or near a previously squished 3d surface to the resulting 2d surface
Public methodSquishMesh(SquishParameters, Mesh)
Squish the given mesh into a flat mesh
Public methodSquishMesh(SquishParameters, Mesh, IEnumerableGeometryBase, ListGeometryBase)
Squish the given mesh into a flat mesh
Public methodSquishPoint
Maps a point on or near the previously squished 3d surface to the flattened surface
Public methodSquishSurface(SquishParameters, Surface)
Squish the surface into a flat brep
Public methodSquishSurface(SquishParameters, Surface, IEnumerableGeometryBase, ListGeometryBase)
Squish the surface into a flat brep
Public methodSquishTextDot
Maps a TextDot on or near a previously squished 3d surface to the resulting 2d surface
Top
See Also