HiddenLineDrawingSegment Class |
Namespace: Rhino.Geometry
The HiddenLineDrawingSegment type exposes the following members.
Name | Description | |
---|---|---|
CurveGeometry | The actual curve geometry | |
CurveSideFills |
The SideFill fields are only valid for visible curves.
With respect to the HiddenLineDrawing, the region to the left (or right respectively) of this curve is
described by CurveSideFills[0] or CurveSideFills[1], respectively. If exactly one of these regions is empty
this is a scene silhouette. If this region contains a surface it is either a surface which in 3-D is adjacent
to this edge or it an surface that is further away from the camera, we call this a shadow surface.
unknown is used for unset values and for projecting curves
| |
Index |
Index of this curve in HiddenLineDrawing.Curves.
| |
IsSceneSilhouette |
Returns true if this curve is a scene silhouette.
| |
ParentCurve |
This curve is a sub-curve of the returned HiddenLineDrawingFullCurve object.
| |
SegmentVisibility |
Returns the segment's visibility
|
Name | Description | |
---|---|---|
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) |