Click or drag to resize

HiddenLineDrawingSegment Properties

The HiddenLineDrawingSegment type exposes the following members.

Properties
  NameDescription
Public propertyCurveGeometry
The actual curve geometry
Public propertyCurveSideFills
The SideFill fields are only valid for visible curves. With respect to the HiddenLineDrawing, the region to the left (or right respectively) of this curve is described by CurveSideFills[0] or CurveSideFills[1], respectively. If exactly one of these regions is empty this is a scene silhouette. If this region contains a surface it is either a surface which in 3-D is adjacent to this edge or it an surface that is further away from the camera, we call this a shadow surface. unknown is used for unset values and for projecting curves
Public propertyIndex
Index of this curve in HiddenLineDrawing.Curves.
Public propertyIsSceneSilhouette
Returns true if this curve is a scene silhouette.
Public propertyParentCurve
This curve is a sub-curve of the returned HiddenLineDrawingFullCurve object.
Public propertySegmentVisibility
Returns the segment's visibility
Top
See Also