Click or drag to resize

ReduceMeshParameters Class

Parameters for Reduce method
Inheritance Hierarchy
SystemObject
  Rhino.GeometryReduceMeshParameters

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class ReduceMeshParameters

The ReduceMeshParameters type exposes the following members.

Constructors
  NameDescription
Public methodReduceMeshParameters
Constructs a polygon reduction parameter object with default values. Users of this class should not rely on default values to stay constant across service releases.
Top
Properties
  NameDescription
Public propertyAccuracy
Integer from 1 to 10 telling how accurate reduction algorithm to use. Greater number gives more accurate results
Public propertyAllowDistortion
If true mesh appearance is not changed even if the target polygon count is not reached
Public propertyCancelToken
Public propertyDesiredPolygonCount
Desired or target number of faces
Public propertyError
Public propertyFaceTags
Public propertyLockedComponents
List of topological mesh vertices and mesh vertices that will not be moved or deleted in reduction process. Each mesh vertex will lock the corresponding topological mesh vertex. In other words it is not possible to have a locked and non-locked mesh vertex at the same location.
Public propertyNormalizeMeshSize
If true mesh is fitted to an axis aligned unit cube until reduction is complete
Public propertyProgressReporter
Top
Methods
  NameDescription
Top
See Also