Click or drag to resize

DevelopableSrf Class

Helpers for developable surface functions
Inheritance Hierarchy
SystemObject
  Rhino.GeometryDevelopableSrf

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class DevelopableSrf

The DevelopableSrf type exposes the following members.

Constructors
  NameDescription
Public methodDevelopableSrf
Initializes a new instance of the DevelopableSrf class
Top
Methods
  NameDescription
Public methodStatic memberGetLocalDevopableRuling
Finds minimum twist ruling between 2 curves at local domains
Public methodStatic memberRulingMinTwist(NurbsCurve, Double, NurbsCurve, Double, Interval, Double, Double)
Find a ruling from rail0(t0) to rail1(t1_out) that has the least twist across the ruling with t1_out in domain1. max_cos_twist is cos(twist) for the returned ruling
Public methodStatic memberRulingMinTwist(NurbsCurve, Double, Interval, NurbsCurve, Double, Interval, Double, Double, Double)
Find a ruling from rail0(t0_out) to rail1(t1_out) that has the least twist across the ruling with t0_out in domain0 and t1_out in domain1. max_cos_twist is cos(twist) for the returned ruling
Public methodStatic memberUntwistRulings
Top
See Also