Click or drag to resize

SweepOneRail Class

Utility class for generating Breps by sweeping cross section curves over a single rail curve. Note, this class has been superseded by the Rhino.Geometry.Brep.CreateFromSweep static functions.
Inheritance Hierarchy
SystemObject
  Rhino.GeometrySweepOneRail

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class SweepOneRail

The SweepOneRail type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleSweepOneRail
Initializes a new instance of the SweepOneRail class
Top
Properties
  NameDescription
Public propertyAngleToleranceRadians
Public propertyClosedSweep
If the input rail is closed, ClosedSweep determines if the swept breps will also be closed.
Public propertyGlobalShapeBlending
If true, the sweep is linearly blended from one end to the other, creating sweeps that taper from one cross-section curve to the other. If false, the sweep stays constant at the ends and changes more rapidly in the middle.
Public propertyIsFreeform
Public propertyIsRoadlike
Public propertyIsRoadlikeFront
Public propertyIsRoadlikeTop
Public propertyIsRoadlineRight
Public propertyMiterType
0: don't miter, 1: intersect surfaces and trim sweeps, 2: rotate shapes at kinks and don't trim.
Public propertySweepTolerance
Top
Methods
  NameDescription
Public methodPerformSweep(Curve, Curve)
Public methodCode examplePerformSweep(Curve, IEnumerableCurve)
Public methodPerformSweep(Curve, Curve, Double)
Public methodPerformSweep(Curve, IEnumerableCurve, IEnumerableDouble)
Public methodPerformSweepRebuild(Curve, Curve, Int32)
Public methodPerformSweepRebuild(Curve, IEnumerableCurve, Int32)
Public methodPerformSweepRebuild(Curve, Curve, Double, Int32)
Public methodPerformSweepRebuild(Curve, IEnumerableCurve, IEnumerableDouble, Int32)
Public methodPerformSweepRefit(Curve, Curve, Double)
Public methodPerformSweepRefit(Curve, IEnumerableCurve, Double)
Public methodPerformSweepRefit(Curve, Curve, Double, Double)
Public methodPerformSweepRefit(Curve, IEnumerableCurve, IEnumerableDouble, Double)
Public methodSetRoadlikeUpDirection
Public methodSetToRoadlikeFront
Public methodSetToRoadlikeRight
Public methodSetToRoadlikeTop
Top
See Also