Click or drag to resize

SweepOneRailPerformSweepRefit Method (Curve, IEnumerableCurve, IEnumerableDouble, Double)

[Missing <summary> documentation for "M:Rhino.Geometry.SweepOneRail.PerformSweepRefit(Rhino.Geometry.Curve,System.Collections.Generic.IEnumerable{Rhino.Geometry.Curve},System.Collections.Generic.IEnumerable{System.Double},System.Double)"]

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Brep[] PerformSweepRefit(
	Curve rail,
	IEnumerable<Curve> crossSections,
	IEnumerable<double> crossSectionParameters,
	double refitTolerance
)

Parameters

rail
Type: Rhino.GeometryCurve

[Missing <param name="rail"/> documentation for "M:Rhino.Geometry.SweepOneRail.PerformSweepRefit(Rhino.Geometry.Curve,System.Collections.Generic.IEnumerable{Rhino.Geometry.Curve},System.Collections.Generic.IEnumerable{System.Double},System.Double)"]

crossSections
Type: System.Collections.GenericIEnumerableCurve

[Missing <param name="crossSections"/> documentation for "M:Rhino.Geometry.SweepOneRail.PerformSweepRefit(Rhino.Geometry.Curve,System.Collections.Generic.IEnumerable{Rhino.Geometry.Curve},System.Collections.Generic.IEnumerable{System.Double},System.Double)"]

crossSectionParameters
Type: System.Collections.GenericIEnumerableDouble

[Missing <param name="crossSectionParameters"/> documentation for "M:Rhino.Geometry.SweepOneRail.PerformSweepRefit(Rhino.Geometry.Curve,System.Collections.Generic.IEnumerable{Rhino.Geometry.Curve},System.Collections.Generic.IEnumerable{System.Double},System.Double)"]

refitTolerance
Type: SystemDouble

[Missing <param name="refitTolerance"/> documentation for "M:Rhino.Geometry.SweepOneRail.PerformSweepRefit(Rhino.Geometry.Curve,System.Collections.Generic.IEnumerable{Rhino.Geometry.Curve},System.Collections.Generic.IEnumerable{System.Double},System.Double)"]

Return Value

Type: Brep

[Missing <returns> documentation for "M:Rhino.Geometry.SweepOneRail.PerformSweepRefit(Rhino.Geometry.Curve,System.Collections.Generic.IEnumerable{Rhino.Geometry.Curve},System.Collections.Generic.IEnumerable{System.Double},System.Double)"]

See Also