Click or drag to resize

MeshingParameters Class

Represents settings used for creating a mesh representation of a brep or surface.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryMeshingParameters

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class MeshingParameters : IDisposable, 
	ISerializable, IEquatable<MeshingParameters>

The MeshingParameters type exposes the following members.

Constructors
  NameDescription
Public methodMeshingParameters
Initializes a new instance with default values.

Initial values are same as Default.

Public methodMeshingParameters(Double)
Initializes a new instance with simple values, similar to that of Rhino's meshing slider interface.
Public methodMeshingParameters(MeshingParameters)
Initializes a new instance copying values from source.

Initial values are same as Default.

Public methodMeshingParameters(Double, Double)
Initializes a new instance with simple values, similar to that of Rhino's meshing slider interface.
Public methodMeshingParameters(SerializationInfo, StreamingContext)
Called by BinaryFormatter.Deserialize to create a new MeshParamaters object.
Top
Properties
  NameDescription
Public propertyClosedObjectPostProcess
Gets or sets a value indicating whether or not to post process non-closed meshes that should be closed. If the Brep being meshed is closed, JaggedSeams = false, and ClosedObjectPostProcess = true, and the resulting mesh is not closed, then a post meshing process is applied to find and close gaps in the mesh. Typically the resulting mesh is not closed because the input Brep has a geometric flaw, like loops in trimming curve.
Public propertyStatic memberCode exampleCoarse Obsolete.
Gets mesh creation parameters for coarse meshing.

This corresponds with the "Jagged and Faster" default in Rhino.

Public propertyComputeCurvature
Gets or sets a value indicating whether or not surface curvature data will be embedded in the mesh.
Public propertyStatic memberCode exampleDefault
Gets mesh creation parameters to create the default render mesh. Only use this if you plan on specifying your own custom meshing parameters.
Public propertyStatic memberDefaultAnalysisMesh
Gets mesh creation parameters to create the default analysis mesh.
Public propertyDoublePrecision
Gets or sets a value indicating whether or not the mesh should have double precision vertices in addition to the floats.
Public propertyStatic memberFastRenderMesh
Gets mesh creation parameters to create the a render mesh when meshing speed is preferred over mesh quality.
Public propertyGridAmplification
Gets or sets the grid amplification factor. Values lower than 1.0 will decrease the number of initial quads, values higher than 1.0 will increase the number of initial quads.
Public propertyGridAngle
Gets or sets the maximum allowed angle difference (in radians) for a single sampling quad. The angle pertains to the surface normals.
Public propertyGridAspectRatio
Gets or sets the maximum allowed aspect ratio of sampling quads.
Public propertyGridMaxCount
Gets or sets the maximum number of grid quads in the initial sampling grid.
Public propertyGridMinCount
Gets or sets the minimum number of grid quads in the initial sampling grid.
Public propertyJaggedSeams
Gets or sets whether or not the mesh is allowed to have jagged seams. When this flag is set to true, meshes on either side of a Brep Edge will not match up.
Public propertyMaximumEdgeLength
Gets or sets the maximum allowed mesh edge length.
Public propertyStatic memberCode exampleMinimal
Gets minimal meshing parameters.
Public propertyMinimumEdgeLength
Gets or sets the minimum allowed mesh edge length.
Public propertyMinimumTolerance
Gets or sets the minimum tolerance.
Public propertyStatic memberQualityRenderMesh
Gets mesh creation parameters to create the a render mesh when mesh quality is preferred over meshing speed.
Public propertyRefineAngle
Gets or sets the mesh parameter refine angle in radians.
Public propertyRefineAngleInDegrees
Gets or sets the mesh parameter refine angle in degrees.
Public propertyRefineGrid
Gets or sets a value indicating whether or not the sampling grid can be refined when certain tolerances are not met.
Public propertyRelativeTolerance
Gets or sets the relative tolerance.
Public propertySimplePlanes
Gets or sets a value indicating whether or not planar areas are allowed to be meshed in a simplified manner.
Public propertyStatic memberCode exampleSmooth Obsolete.
Gets mesh creation parameters for smooth meshing.

This corresponds with the "Smooth and Slower" default in Rhino.

Public propertyTextureRange
Gets or sets how and if textures will be packed.
Public propertyTolerance
Gets or sets the maximum allowed edge deviation. This tolerance is measured between the center of the mesh edge and the surface.
Top
Methods
  NameDescription
Public methodCopyFrom
Call this method to copy MeshingParameters from another instance.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodStatic memberDocumentCurrentSetting
Gets the MeshingParameters that are currently set for a document. These are the same settings that are shown in the DocumentProperties "mesh settings" user interface.
Public methodEquals(MeshingParameters)
Determines whether the specified MeshingParameters has the same values as the present MeshingParameters.
Public methodEquals(Object)
Determines whether the specified MeshingParameters has the same values as the present MeshingParameters.
(Overrides ObjectEquals(Object).)
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodStatic memberFromEncodedString
Converts encoded serialized string into a MeshingParameters
Public methodGetHashCode
Computes a hash number that represents the current MeshingParameters.
(Overrides ObjectGetHashCode.)
Public methodGetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
Public methodSetSubDDisplayParameters
Sets the SubD display parameters.
Public methodSubDDisplayParameters
Gets the SubD display parameters.
Public methodToEncodedString
Returns a encoded string that represents the MeshingParameters.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Determines whether the two MeshingParameters have equal values.
Public operatorStatic memberInequality
Determines whether the two MeshingParameters do not have equal values.
Top
See Also