Click or drag to resize

MeshingParameters Methods

The MeshingParameters type exposes the following members.

Methods
  NameDescription
Public methodCopyFrom
Call this method to copy MeshingParameters from another instance.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodStatic memberDocumentCurrentSetting
Gets the MeshingParameters that are currently set for a document. These are the same settings that are shown in the DocumentProperties "mesh settings" user interface.
Public methodEquals(MeshingParameters)
Determines whether the specified MeshingParameters has the same values as the present MeshingParameters.
Public methodEquals(Object)
Determines whether the specified MeshingParameters has the same values as the present MeshingParameters.
(Overrides ObjectEquals(Object).)
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodStatic memberFromEncodedString
Converts encoded serialized string into a MeshingParameters
Public methodGetHashCode
Computes a hash number that represents the current MeshingParameters.
(Overrides ObjectGetHashCode.)
Public methodGetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
Public methodSetSubDDisplayParameters
Sets the SubD display parameters.
Public methodSubDDisplayParameters
Gets the SubD display parameters.
Public methodToEncodedString
Returns a encoded string that represents the MeshingParameters.
Top
See Also