Click or drag to resize

MeshDisplacementInfo Class

Contains mesh displacement information.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryMeshDisplacementInfo

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshDisplacementInfo

The MeshDisplacementInfo type exposes the following members.

Constructors
  NameDescription
Public methodMeshDisplacementInfo
Constructs a displacement information instance with default values. Users of this class should not rely on default values to stay constant across service releases.
Top
Properties
  NameDescription
Public propertyBlack
Value considered lowest point in the displacement.
Public propertyBlackMove
The amount of displacement for the black color in the texture.
Public propertyChannelNumber
Mapping channel number for the displacement mapping.
Public propertyFaceLimit
Runs a mesh reduction as a post process o simplify the result of displacement to meet the specified number of faces.
Public propertyFairingAmount
Straightens rough feature edges. The value specifies the number of passes.
Public propertyInstanceTransform
Instance transformation of the mesh.
Public propertyMapping
The texture mapping of the mesh.
Public propertyMappingTransform
Texture mapping transform.
Public propertyMemoryLimit
Specifies how much memory can be allocated for use by the displacement mesh. Value in megabytes.
Public propertyPostWeldAngle
Specifies the maximum angle between face normals of adjacent faces that will get welded together.
Public propertyRefineSensitivity

Specifies how sensitive the divider for contrasts is on the displacement texture.

Specify 1 to split all mesh edges on each refine step.

Specify 0.99 to make even slight contrasts on the displacement texture cause edges to be split.

Specifying 0.01 only splits edges where heavy contrast exists.

Public propertyRefineStepCount
Specifies the number of refinement passes.
Public propertySweepPitch
Specifies how densely the object is initially subdivided. The lower the value, the higher the resolution of the displaced mesh.
Public propertyTexture
The texture used as displacement.
Public propertyWhite
Value considered highest point of the displacement texture.
Public propertyWhiteMove
The amount of displacement for the white color in the texture.
Top
Methods
  NameDescription
Top
See Also