Click or drag to resize

Unroller Class

Represents the operation of unrolling a single surface.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryUnroller

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Unroller

The Unroller type exposes the following members.

Constructors
  NameDescription
Public methodUnroller(Brep)
Initializes a new instance of the Unroller class with a brep.
Public methodUnroller(Surface)
Initializes a new instance of the Unroller class with surface.
Top
Properties
  NameDescription
Public propertyAbsoluteTolerance
Gets or sets the absolute tolerance for the unrolling operation.

Absolute tolerance is used in the evaluation of new entities, such as intersections, re-projections and splits.

In the current implementation, absolute tolerance is used in tessellating rails, fitting curves and pulling back trims.

Public propertyExplodeOutput
Gets or sets a value determining whether geometry should be exploded.
Public propertyExplodeSpacing
Gets or sets a value determining whether spacing should be exploded.
Public propertyRelativeTolerance
Gets or sets the relative tolerance for the unrolling operation.

Relative tolerance is used in the evaluation of intrinsic properties, such as computations "along" the surface or brep.

In the current implementation, relative tolerance is used to decide if a surface is flat enough to try to unroll. That helps ease the scale dependency. The surface has to be linear in one direction within (length * RelativeTolerance) to be considered linear for that purpose. Otherwise smash will ignore that tolerance and unroll anything.

Top
Methods
  NameDescription
Public methodAddFollowingGeometry(Curve)
Adds a curve that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerableCurve)
Adds curves that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerablePoint3d)
Adds points that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerableTextDot)
Adds text dots that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(Point)
Adds a point that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(Point3d)
Adds a point that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(TextDot)
Adds a text dot that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerablePoint3d, IEnumerableString)
Adds text dots that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(Point3d, String)
Adds a text dot that should be unrolled along with the surface/brep.
Public methodFollowingGeometryIndex(Curve)
Given an unrolled curve, returns the index of the source, or following curve.
Public methodFollowingGeometryIndex(TextDot)
Given an unrolled text dot, returns the index of the source, or following text dot.
Public methodPerformUnroll(ListBrep)
Executes unrolling operations.
Public methodPerformUnroll(Curve, Point3d, TextDot)
Executes unrolling operations.
Top
See Also