Click or drag to resize

Unroller Methods

The Unroller type exposes the following members.

Methods
  NameDescription
Public methodAddFollowingGeometry(Curve)
Adds a curve that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerableCurve)
Adds curves that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerablePoint3d)
Adds points that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerableTextDot)
Adds text dots that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(Point)
Adds a point that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(Point3d)
Adds a point that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(TextDot)
Adds a text dot that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(IEnumerablePoint3d, IEnumerableString)
Adds text dots that should be unrolled along with the surface/brep.
Public methodAddFollowingGeometry(Point3d, String)
Adds a text dot that should be unrolled along with the surface/brep.
Public methodFollowingGeometryIndex(Curve)
Given an unrolled curve, returns the index of the source, or following curve.
Public methodFollowingGeometryIndex(TextDot)
Given an unrolled text dot, returns the index of the source, or following text dot.
Public methodPerformUnroll(ListBrep)
Executes unrolling operations.
Public methodPerformUnroll(Curve, Point3d, TextDot)
Executes unrolling operations.
Top
See Also