ParticleSystem Class |
[Missing <summary> documentation for "T:Rhino.Geometry.ParticleSystem"]
Namespace: Rhino.Geometry
The ParticleSystem type exposes the following members.
Name | Description | |
---|---|---|
ParticleSystem | Initializes a new instance of the ParticleSystem class |
Name | Description | |
---|---|---|
Add |
Adds a particle to this ParticleSystem. A Particle can only be in one system
at a time. If the Particle already exists in a different system, this function
will return false. You should remove the particle from the other system first
before adding it.
| |
Clear |
Remove all Particles from this system.
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) | |
GetEnumerator | ||
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
Remove |
Removes a single particle from this system.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
Update |
Calls Update on every particle in the system.
|