Click or drag to resize

ParticleSystemAdd Method

Adds a particle to this ParticleSystem. A Particle can only be in one system at a time. If the Particle already exists in a different system, this function will return false. You should remove the particle from the other system first before adding it.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public virtual bool Add(
	Particle particle
)

Parameters

particle
Type: Rhino.GeometryParticle
A particle to be added.

Return Value

Type: Boolean
true if this particle was added to the system or if is already in the system. false if the particle already exists in a different system.
See Also