RadialDimension Class |
Namespace: Rhino.Geometry
The RadialDimension type exposes the following members.
Name | Description | |
---|---|---|
RadialDimension |
Constructs a radial dimension.
| |
RadialDimension(SerializationInfo, StreamingContext) | Protected constructor used in serialization. | |
RadialDimension(AnnotationType, Plane, Point3d, Point3d, Point3d) |
Constructs a radial dimension from parameters.
|
Name | Description | |
---|---|---|
AlternateBelowLine | (Inherited from Dimension.) | |
AlternateDimensionLengthDisplay |
Alternate length display units and format
(Inherited from AnnotationBase.) | |
AltLengthFactor | (Inherited from Dimension.) | |
AltLengthResolution | (Inherited from Dimension.) | |
AltLengthRoundoff | (Inherited from Dimension.) | |
AltPrefix | (Inherited from Dimension.) | |
AltSuffix | (Inherited from Dimension.) | |
AltToleranceResolution | (Inherited from Dimension.) | |
AltUnitsDisplay | (Inherited from Dimension.) | |
AltZeroSuppression | (Inherited from Dimension.) | |
AnnotationType | ||
ArrowBlockId1 | (Inherited from Dimension.) | |
ArrowBlockId2 | (Inherited from Dimension.) | |
ArrowFit | (Inherited from Dimension.) | |
ArrowheadType1 | (Inherited from Dimension.) | |
ArrowheadType2 | (Inherited from Dimension.) | |
ArrowSize | (Inherited from Dimension.) | |
BaselineSpacing | (Inherited from Dimension.) | |
CentermarkSize | (Inherited from Dimension.) | |
CentermarkStyle | (Inherited from Dimension.) | |
CenterPoint | ||
DecimalSeparator |
Set or get the decimal separator c
(Inherited from AnnotationBase.) | |
DetailMeasured | (Inherited from Dimension.) | |
DimensionLengthDisplay |
Length display units and format
(Inherited from AnnotationBase.) | |
DimensionLineExtension | (Inherited from Dimension.) | |
DimensionScale |
Gets or sets the dimension scale
(Inherited from AnnotationBase.) | |
DimensionStyle |
If there are no overrides then the parent style is returned otherwise the dimension style saved with the annotation is returned.
(Inherited from AnnotationBase.) | |
DimensionStyleId |
Id of this annotation's parent dimstyle
If this annotation has overrides to dimstyle properties,
those overrides will be represented in the DimensionStyle
returned by DimensionStyle(ParentStyle)
(Inherited from AnnotationBase.) | |
DimlinePoint | ||
Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) | |
DistanceScale | (Inherited from Dimension.) | |
DrawForward |
Gets or sets whether the text is oriented towards the reader when viewed from behind
(Inherited from AnnotationBase.) | |
DrawTextFrame | Obsolete.
Gets or sets whether to draw a frame around a text mask
(Inherited from AnnotationBase.) | |
ExtensionLineExtension | (Inherited from Dimension.) | |
ExtensionLineOffset | (Inherited from Dimension.) | |
FirstCharFont |
Returns the font used by the first run of text in an annotation
(Inherited from AnnotationBase.) | |
FixedExtensionLength | (Inherited from Dimension.) | |
FixedLengthExtensionOn | (Inherited from Dimension.) | |
Font |
The base Font for the text of the annotation. The text string is rich text and therefore a different font that the base font can be associated with sub strings of the text
(Inherited from AnnotationBase.) | |
ForceArrowPosition | Obsolete. (Inherited from Dimension.) | |
ForceDimensionLineBetweenExtensionLines | (Inherited from Dimension.) | |
ForceDimLine | (Inherited from Dimension.) | |
ForceTextPosition | Obsolete. (Inherited from Dimension.) | |
FormatWidth | Text format width (Wrapping rectangle) (Inherited from AnnotationBase.) | |
HasBrepForm |
Returns true if the Brep.TryConvertBrep function will be successful for this object
(Inherited from GeometryBase.) | |
HasPropertyOverrides | (Inherited from AnnotationBase.) | |
HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) | |
IsDeformable |
true if object can be accurately modified with "squishy" transformations like
projections, shears, and non-uniform scaling.
(Inherited from GeometryBase.) | |
IsDiameterDimension |
Gets a value indicating whether the value refers to the diameter, rather than the radius.
| |
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from GeometryBase.) | |
IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) | |
KneePoint | ||
LeaderArrowBlockId | ||
LeaderArrowSize | ||
LeaderArrowType | ||
LeaderCurveStyle | ||
LeaderTextHorizontalAlignment |
Gets or sets the horizontal alignment of the radial dimension's text
| |
LengthFactor | (Inherited from Dimension.) | |
LengthResolution | (Inherited from Dimension.) | |
LengthRoundoff | (Inherited from Dimension.) | |
MaskColor |
Color to use for drawing a text mask when it is enabled. If the mask is
enabled and MaskColor is System.Drawing.Color.Transparent, then the
viewport's color will be used for the MaskColor
(Inherited from AnnotationBase.) | |
MaskColorSource |
Gets or sets whether the mask background color is from the background or from a color
(Inherited from AnnotationBase.) | |
MaskEnabled |
Determines whether or not to draw a Text Mask
(Inherited from AnnotationBase.) | |
MaskFrame |
Gets or sets whether to draw a frame around a text mask
(Inherited from AnnotationBase.) | |
MaskOffset |
Offset for the border around text of the rectangle used to draw the mask. This
value multiplied by TextHeight is the offset on each side of the tight rectangle
around the text characters to the mask rectangle. The default value is 0.1.
(Inherited from AnnotationBase.) | |
MaskUsesViewportColor |
If true, the viewport's color is used for the mask color. If
false, the color defined by MaskColor is used
(Inherited from AnnotationBase.) | |
NumericValue |
Gets the numeric value (or measurement), depending on geometry type.
(Inherited from Dimension.)LinearDimension: distance between arrow tips RadialDimension: radius or diameter depending on type AngularDimension: angle in radians | |
ObjectType |
Useful for switch statements that need to differentiate between
basic object types like points, curves, surfaces, and so on.
(Inherited from GeometryBase.) | |
ParentDimensionStyle |
The parent dimension style associated with this annotation
(Inherited from AnnotationBase.) | |
PlainText |
Text stripped of RTF formatting information
(Inherited from AnnotationBase.) | |
PlainTextWithFields |
Text stripped of RTF formatting information and with field expressions intact
(Inherited from AnnotationBase.) | |
PlainUserText | (Inherited from Dimension.) | |
Plane | Plane that this annotation lies on (Inherited from AnnotationBase.) | |
Prefix | (Inherited from Dimension.) | |
RadiusPoint | ||
RichText |
Text including additional RTF formatting information
(Inherited from AnnotationBase.) | |
Suffix | (Inherited from Dimension.) | |
SuppressExtension1 | (Inherited from Dimension.) | |
SuppressExtension2 | (Inherited from Dimension.) | |
Text | Obsolete.
Text including additional RTF formatting information
(Inherited from AnnotationBase.) | |
TextAngleType | (Overrides DimensionTextAngleType.) | |
TextFit | (Inherited from Dimension.) | |
TextFormula | (Inherited from Dimension.) | |
TextHasRtfFormatting | (Inherited from AnnotationBase.) | |
TextHeight |
AnnotationBase.TextHeight
Gets the parent dimstyle for the annotation and
gets or sets the text height in the dimstyle
(Inherited from AnnotationBase.) | |
TextIsWrapped |
Is text wrapping on
(Inherited from AnnotationBase.) | |
TextLocation | (Overrides DimensionTextLocation.) | |
TextModelWidth |
Width of text in the model
(Inherited from AnnotationBase.) | |
TextOrientation | (Overrides DimensionTextOrientation.) | |
TextPosition |
Gets and sets the position of text on the plane.
(Inherited from Dimension.) | |
TextRotation | (Inherited from Dimension.) | |
TextRotationDegrees |
Rotation of text in degrees
(Inherited from AnnotationBase.) | |
TextRotationRadians |
Rotation of text in radians
(Inherited from AnnotationBase.) | |
ToleranceFormat | (Inherited from Dimension.) | |
ToleranceHeightScale | (Inherited from Dimension.) | |
ToleranceLowerValue | (Inherited from Dimension.) | |
ToleranceResolution | (Inherited from Dimension.) | |
ToleranceUpperValue | (Inherited from Dimension.) | |
UseDefaultTextPoint | (Inherited from Dimension.) | |
UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) | |
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
(Inherited from CommonObject.) | |
UserStringCount |
Gets the amount of user strings.
(Inherited from GeometryBase.) | |
ZeroSuppression | (Inherited from Dimension.) |
Name | Description | |
---|---|---|
AdjustFromPoints |
Update Dimension geometry from point locations
| |
ClearPropertyOverrides |
Clears all overridden properties for this annotation
(Inherited from AnnotationBase.) | |
ComponentIndex |
If this piece of geometry is a component in something larger, like a BrepEdge
in a Brep, then this function returns the component index.
(Inherited from GeometryBase.) | |
ConstructConstObject |
Assigns a parent object and a sub-object index to this.
(Inherited from CommonObject.) | |
Create |
Initialize Dimension parameters
| |
DataCRC |
Returns a CRC calculated from the information that defines the object.
This CRC can be used as a quick way to see if two objects are not identical.
(Inherited from GeometryBase.) | |
DeleteAllUserStrings | (Inherited from GeometryBase.) | |
DeleteUserString | (Inherited from GeometryBase.) | |
Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) | |
Dispose(Boolean) |
Overridden in order to destroy local display cache information
(Inherited from GeometryBase.) | |
Duplicate |
Constructs a deep (full) copy of this object.
(Inherited from GeometryBase.) | |
DuplicateShallow |
Constructs a light copy of this object. By "light", it is meant that the same
underlying data is used until something is done to attempt to change it. For example,
you could have a shallow copy of a very heavy mesh object and the same underlying
data will be used when doing things like inspecting the number of faces on the mesh.
If you modify the location of one of the mesh vertices, the shallow copy will create
a full duplicate of the underlying mesh data and the shallow copy will become a
deep copy.
(Inherited from GeometryBase.) | |
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Explode |
Explodes this dimension into its geometric components.
(Inherited from Dimension.) | |
Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) | |
Get3dPoints |
Get locations of dimension's 3d points
| |
GetBoundingBox(Boolean) |
Bounding box solver. Gets the world axis aligned bounding box for the geometry.
(Inherited from GeometryBase.) | |
GetBoundingBox(Plane) |
Aligned Bounding box solver. Gets the plane aligned bounding box.
(Inherited from GeometryBase.) | |
GetBoundingBox(Transform) |
Aligned bounding box solver. Gets the world axis aligned bounding box for the transformed geometry.
(Inherited from AnnotationBase.) | |
GetBoundingBox(Plane, Box) |
Aligned Bounding box solver. Gets the plane aligned bounding box.
(Inherited from GeometryBase.) | |
GetDimensionStyle |
Return the proper dimension style from which to get properties
for this annotation object
If this object has style overrides, those will be included in the
returned dimension style and the style will be updated to include
the current state of the parent style for non-overridden fields
(Inherited from AnnotationBase.) | |
GetDisplayLines | ||
GetDistanceDisplayText | ||
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) | |
GetPlainTextWithRunMap |
Return plain text string for this annotation with field expressions unevaluated.
(Inherited from AnnotationBase.) | |
GetTextRectangle | ||
GetTextTransform | Get the transform for this text object's text geometry (Inherited from Dimension.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
GetUserString |
Gets user string from this geometry.
(Inherited from GeometryBase.) | |
GetUserStrings |
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
(Inherited from GeometryBase.) | |
IsAllBold |
Returns true if all of the text in the annotation is Bold, otherwise returns false
(Inherited from AnnotationBase.) | |
IsAllItalic |
Returns true if all of the text in the annotation is Italic, otherwise returns false
(Inherited from AnnotationBase.) | |
IsAllUnderlined |
Returns true if all of the text in the annotation is Underlined, otherwise returns false
(Inherited from AnnotationBase.) | |
IsPropertyOverridden |
Returns true if a property is overridden
(Inherited from AnnotationBase.) | |
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) | |
MakeDeformable |
If possible, converts the object into a form that can be accurately modified
with "squishy" transformations like projections, shears, an non-uniform scaling.
(Inherited from GeometryBase.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
(Inherited from GeometryBase.) | |
NonConstOperation |
Destroy cache handle
(Inherited from GeometryBase.) | |
OnSwitchToNonConst |
Is called when a non-constant operation occurs.
(Inherited from GeometryBase.) | |
Rotate |
Rotates the object about the specified axis. A positive rotation
angle results in a counter-clockwise rotation about the axis (right hand rule).
(Inherited from GeometryBase.) | |
RunReplace |
Replace text within a formatted string
(Inherited from AnnotationBase.) | |
Scale |
Scales the object by the specified factor. The scale is centered at the origin.
(Inherited from GeometryBase.) | |
SetAltDimensionLengthDisplayWithZeroSuppressionReset | (Inherited from Dimension.) | |
SetBold | (Inherited from AnnotationBase.) | |
SetDimensionLengthDisplayWithZeroSuppressionReset | (Inherited from Dimension.) | |
SetFacename | (Inherited from AnnotationBase.) | |
SetItalic | (Inherited from AnnotationBase.) | |
SetOverrideDimStyle |
Set a style including overrides for this annotation object.
The DimensionStyle OverrideStyle must have the override fields marked
as overridden and must have it's Id set to nil.
Use DimensinoStyle.SetFieldOverride(Field field) and related functions
to manage override settings. To override a field, the field value must be set
and the field must be marked as an override.
The DimensionStyle passed in here must not be in the dimstyle table
(Inherited from AnnotationBase.) | |
SetRichText | (Inherited from AnnotationBase.) | |
SetUnderline | (Inherited from AnnotationBase.) | |
SetUserString |
Attach a user string (key,value combination) to this geometry.
(Inherited from GeometryBase.) | |
ToJSON |
Create a JSON string representation of this object
(Inherited from CommonObject.) | |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
Transform |
Transforms the geometry. If the input Transform has a SimilarityType of
OrientationReversing, you may want to consider flipping the transformed
geometry after calling this function when it makes sense. For example,
you may want to call Flip() on a Brep after transforming it.
(Inherited from GeometryBase.) | |
Translate(Vector3d) | Translates the object along the specified vector. (Inherited from GeometryBase.) | |
Translate(Double, Double, Double) | Translates the object along the specified vector. (Inherited from GeometryBase.) | |
UpdateDimensionText |
Remakes dimension text geometry object and sets it on the dimension.
(Inherited from Dimension.) | |
WrapText |
Wrap text
(Inherited from AnnotationBase.) |