Click or drag to resize

CurveBooleanRegions Class

Represents the results of a Curve.CreateBooleanRegions calculation.
Inheritance Hierarchy
SystemObject
  Rhino.GeometryCurveBooleanRegions

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class CurveBooleanRegions : IDisposable

The CurveBooleanRegions type exposes the following members.

Constructors
  NameDescription
Protected methodCurveBooleanRegions
Protected constructor used in serialization.
Top
Properties
  NameDescription
Public propertyPlanarCurveCount
Returns number of planar curves that were calculated by Curve.CreateBooleanRegions.
Public propertyPointCount
If this object were created using the Curve.CreateBooleanRegions override that accepts a collection of points as input, then this value will be equal to the length of the points collection.
Public propertyRegionCount
Returns the number of curve regions. A curve region is a collection of curves that bound a single connected region of the plane.
Top
Methods
  NameDescription
Public methodBoundaryCount
Returns the number of boundary curves in a curve region.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method.
Public methodPlanarCurve
Returns a planar curve that was calculated by Curve.CreateBooleanRegions.
Public methodRegionCurves
Returns the boundary curves in a curve region. A curve region is a collection of curves that bound a single connected region of the plane. Note, the first curve is always the outer boundary.
Public methodRegionPointIndex
If this object were created using the Curve.CreateBooleanRegions override that accepts a collection of points as input, then you this method to retrieve the index of the point contained in a curve region. If this.RegionPointIndex(i) = n, then points[i] is contained in this.RegionCurves(n). If points[i] is not in any region, then this.RegionPointIndex(i) = -1.
Public methodSegmentCount
Returns the number of segments in a boundary curve in a curve region.
Public methodSegmentDetails
Returns the details of a segment in a boundary curve in a curve region.
Top
See Also