Click or drag to resize

BezierCurve Class

Represents a Bezier curve.

Note: as an exception, the bezier curve is not derived from Curve.

Inheritance Hierarchy
SystemObject
  Rhino.GeometryBezierCurve

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class BezierCurve : IDisposable, 
	ISerializable

The BezierCurve type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyControlVertexCount
Number of control vertices in this curve
Public propertyDimension
Dimension of Bezier
Public propertyIsRational
Gets a value indicating whether or not the curve is rational. Rational curves have control-points with custom weights.
Public propertyIsValid
Tests an object to see if it is valid.
Top
Methods
  NameDescription
Public methodChangeDimension
Change dimension of bezier.
Public methodStatic memberCreateBeziers
Create an array of Bezier curves that fit to an existing curve. Please note, these Beziers can be of any order and may be rational.
Public methodStatic memberCreateCubicBeziers
Constructs an array of cubic, non-rational Beziers that fit a curve to a tolerance.
Public methodStatic memberCreateLoftedBezier(IEnumerablePoint2d)
Loft a bezier through a list of points
Public methodStatic memberCreateLoftedBezier(IEnumerablePoint3d)
Loft a bezier through a list of points
Public methodCurvatureAt
Evaluate the curvature vector at a curve parameter.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGetBoundingBox
Bounding box solver. Gets the world axis aligned bounding box for the curve.
Public methodGetControlVertex2d
Get location of a control vertex.
Public methodGetControlVertex3d
Get location of a control vertex.
Public methodGetControlVertex4d
Get location of a control vertex.
Public methodGetObjectData
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
Public methodIncreaseDegree
Increase degree of bezier
Public methodMakeNonRational
Make bezier non-rational
Public methodMakeRational
Make bezier rational
Public methodPointAt
Evaluates point at a curve parameter.
Public methodSplit
Divides the Bezier curve at the specified parameter.
Public methodTangentAt
Evaluates the unit tangent vector at a curve parameter.
Public methodToNurbsCurve
Constructs a NURBS curve representation of this curve.
Top
See Also