Click or drag to resize

BezierCurveGetControlVertex2d Method

Get location of a control vertex.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public Point2d GetControlVertex2d(
	int index
)

Parameters

index
Type: SystemInt32
Control vertex index (0 <= index < ControlVertexCount)

Return Value

Type: Point2d
If the bezier is rational, the euclidean location is returned.
Exceptions
ExceptionCondition
ArgumentOutOfRangeExceptionwhen index is out of range
See Also